[RESOLVED] High response times
Incident Report for FreeAgent CRM
Resolved
02:20 P.M PST There is an issue where response times are very high and service is very slow
02:30 P.M PST Identified the issue and fix is in progress
02:35 P.M PST The issue is currently being addressed and response times are returning to normal.
02:40 P.M PST Issue is resolved and service is back to normal
Posted Feb 22, 2023 - 04:30 CST