Create records and sending emails -
Incident Report for FreeAgent CRM
Postmortem

Normal DB maintenance caused outage due to incorrect analysis of dependencies. Though issue was identified within minutes, restoration of service took too long due to the nature of the fix required. Corrective action is to “soak” this class of normal db maintenance in engineering for a minimum of 1 week prior to application in production.

Posted Nov 07, 2022 - 11:49 CST

Resolved
Service has been restored. We are continuing to monitor all services for any further issues.
Posted Nov 07, 2022 - 11:32 CST
Update
Restoring service requiring DB restore - new ETA is 10:30am central / 9:30am pacific.
Posted Nov 07, 2022 - 10:53 CST
Update
We encountered a problem re-starting services and are attempting to restore service. Login was impacted across all customers - users see "Internal error" when attempting to login.
Posted Nov 07, 2022 - 10:08 CST
Update
Fix is requiring a restart of FreeAgent services. Resolution ETA revised to 8:55am central
Posted Nov 07, 2022 - 09:43 CST
Identified
We have identified the issue and are in the process of restoring service.
Posted Nov 07, 2022 - 09:34 CST
Investigating
There is an issue creating records and sending emails. It began 8:20am central time and is ongoing. We anticipate restoring service for these function by 8:40am central time. Please note statuspage is using pre-time change values (CST)
Posted Nov 07, 2022 - 09:33 CST
This incident affected: Web UI.