[RESOLVED]FreeAgent CRM Mobile App Down
Incident Report for FreeAgent CRM
Resolved
09:45 AM PST The FreeAgent CRM Mobile App is not working and throwing a white screen for some iOS and Android customers.
02:00 PM PST The Issue is RESOLVED and the Mobile App is Completely Operational.
Posted Nov 02, 2022 - 12:00 CDT