FreeAgent Site is currently Unavailable.
Incident Report for FreeAgent CRM
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 10:31 CST
Investigating
Dear FreeAgent Customers,

We have an outage of our systems affecting access to FreeAgent Web and Mobile. We are working on the issue and will update everyone as soon as possible. Thank you for your patience and understanding.
Posted Mar 01, 2022 - 10:10 CST
This incident affected: Web UI and Mobile.