Create and Update Events Failed for 30 Minutes
Incident Report for FreeAgent CRM
Postmortem

It is standard practice that all API-level or schema changes to FreeAgent are backwards compatible. In this case that practice wasn’t followed & we failed to perform a backwards compatibility test prior to a canary deployment. In a canary deployment the old system and new system run under the same schema and set of API’s, which in this case caused create and edit actions on the old system to fail. The fix here is to test backwards compatibility for any deployment that will go thru a canary deployment.

Posted Aug 18, 2020 - 13:00 CDT

Resolved
Create and update events failed following a test deployment of new capabilities, due to a non backwards-compatible schema change. Read operations were unaffected.
Posted Aug 04, 2020 - 21:00 CDT