AWS Outage
Incident Report for FreeAgent CRM
Resolved
AWS partial outage has concluded. All services are available. Root cause investigation underway for event.
Posted Aug 12, 2022 - 08:53 CDT
Investigating
Partial AWS Outage impacting login for all Hazel customers. Remediation underway.
Posted Aug 12, 2022 - 08:36 CDT
This incident affected: Automations, Workflow, Web UI, and Mobile.