No Access to Deals App for 54 Minutes
Incident Report for FreeAgent CRM
Postmortem

There is a periodic maintenance script that runs to remove un-necessary data and ensure good system performance. This script encountered an unexpected data condition that triggered an mistaken update to system configuration that removed the Deals App from the navigation menu. This incorrect configuration persisted for 54 minutes in the middle of the night.

The resolution was to fix the maintenance script, removing its ability to affect system wide configuration settings. We also corrected the unexpected data condition as well.

Posted Aug 18, 2020 - 13:09 CDT

Resolved
A database cleanup routine mistakenly removed a system-wide configuration that provided navigation access to the Deals App for customers. This occurred at 12:12am Central and was resolved by 1:06am Central.
Posted Jul 11, 2020 - 01:00 CDT